*

Help!

Problemen met uw pc? De vrijwilligers van oplossing.be zoeken gratis met u mee! 8)

Meer weten over Oplossing.be?

Hoe stel ik een vraag?

Recent

Auteur Topic: aantal als  (gelezen 789 keer)

Offline Tobora

  • Nieuw lid
  • Berichten: 6
  • Geslacht: Man
  • Oplossing.be
aantal als
« Gepost op: 22 maart 2018, 12:01:13 »
Beste,
misschien doe ik iets verkeerd maar geraak er even niet uit.
Als ik in de formule met aantal als de letter M tel kom ik uit op 2
Maar als ik de letter M met willekeurig cijfer optel kom ik samen op 4 terwijl het maar 2 mag zijn.
Hoe kan ik dat toch laten apart optellen.

Offline alfa

  • Lid
  • *
  • Berichten: 62
  • Oplossing.be
Re: aantal als
« Reactie #1 Gepost op: 22 maart 2018, 12:28:24 »
Met =aantal.als(a2:a5;"m") tel je het aantal cellen waarvan de cel alleen de letter m (en niets anders) bevat; dat zijn 2 cellen.
Met =aantal.als(a2:a5;"m*") tel je het aantal cellen waarvan de celwaarde begint met de letter m en waarbij er na de letter m ofwel niets ofwel nog wat anders komt; dat zijn 4 cellen.
Wat wil je eigenlijk berekenen?
Gelieve uw systeemgegevens in te vullen. Klik HIER voor meer informatie.

Offline Tobora

  • Nieuw lid
  • Berichten: 6
  • Geslacht: Man
  • Oplossing.be
Re: aantal als
« Reactie #2 Gepost op: 22 maart 2018, 12:35:19 »
Gewoon de cellen met enkel "M"apart in een cel en de cellen  met M*(cijfer) ook in aparte cel

Offline alfa

  • Lid
  • *
  • Berichten: 62
  • Oplossing.be
Re: aantal als
« Reactie #3 Gepost op: 22 maart 2018, 12:40:41 »
Gewoon de cellen met enkel "M"apart in een cel en de cellen  met M*(cijfer) ook in aparte cel
Dan is nog de vraag of je die afzonderlijk wil berekenen of beide tezamen. Het antwoord/de antwoorden is/zijn dan de functie(s) die hierboven en in jouw file staan vermeld.
Gelieve uw systeemgegevens in te vullen. Klik HIER voor meer informatie.

Offline Tobora

  • Nieuw lid
  • Berichten: 6
  • Geslacht: Man
  • Oplossing.be
Re: aantal als
« Reactie #4 Gepost op: 22 maart 2018, 12:45:02 »
Allebei afzonderlijk
In cel c2 aantal 2
In cel c3 ook 2
Totaal is niet belangrijk

Offline alfa

  • Lid
  • *
  • Berichten: 62
  • Oplossing.be
Re: aantal als
« Reactie #5 Gepost op: 22 maart 2018, 12:49:48 »
Het aantal met "m" is 2 en het aantal met "m*" is 4, zoals ik je hierboven heb proberen uit te leggen. Waarin bestaat voor jou het verschil voor wat je in C2 en C3 wil?
Gelieve uw systeemgegevens in te vullen. Klik HIER voor meer informatie.

Offline alfa

  • Lid
  • *
  • Berichten: 62
  • Oplossing.be
Re: aantal als
« Reactie #6 Gepost op: 22 maart 2018, 12:56:15 »
Afhankelijk van het aantal tekens dat ná de letter m kan komen, kun je nog wat anders gebruiken. Voorbeeld: als na de letter m maximaal 2 tekens kunnen komen, kun je dit gebruiken:
=AANTAL.ALS(A2:A5;"m?")+AANTAL.ALS(A2:A5;"m??")
Gelieve uw systeemgegevens in te vullen. Klik HIER voor meer informatie.

Offline alfa

  • Lid
  • *
  • Berichten: 62
  • Oplossing.be
Re: aantal als
« Reactie #7 Gepost op: 22 maart 2018, 13:12:05 »
Als je in C2 wil weergeven het aantal cellen dat alleen een m bevat, gebruik dan wat je al had, nl:
=AANTAL.ALS(A2:A5;"m") .
Als je in C3 wil weergeven het aantal cellen dat als eerste teken een m bevat én rechts naast die m nog wat anders (ongeacht het aantal tekens daarvan), gebruik dan:
=AANTAL.ALS(A2:A5;"m*")-AANTAL.ALS(A2:A5;"m")
Gelieve uw systeemgegevens in te vullen. Klik HIER voor meer informatie.

Offline Tobora

  • Nieuw lid
  • Berichten: 6
  • Geslacht: Man
  • Oplossing.be
Re: aantal als
« Reactie #8 Gepost op: 23 maart 2018, 10:37:12 »
Bedankt voor de oplossing
Ik zag even het bos door de bomen niet meer
Echt bedankt

 


www.combell.com