*

Help!

Problemen met uw pc? De vrijwilligers van oplossing.be zoeken gratis met u mee! 8)

Meer weten over Oplossing.be?

Hoe stel ik een vraag?

Recent

Auteur Topic: ivm automatisch aanvullen met datums van die maand op basis van maandnummer  (gelezen 221 keer)

Offline knopperke

  • Lid
  • *
  • Berichten: 58
  • Oplossing.be
Ik heb een eind geleden een oplossing gekregen van iemand, waarvoor nogmaals mijn dank, om de dagen en data automatisch door te voeren op basis van een maand/maandnummer, en op basis van het jaar. Maar ik wil een extra veld bij de data vanaf 28e tem de 31e van een maand. Ik wil dat bij de laatste datums geen datum voorkomt van de volgende maand. Wie kan me nog eens uit de nood helpen? (zie bestand in bijlage).

Als de maand bvb. februari, dus maandnummer 2 is, gaan alle datums netjes van de 1e tem de 28e, maar als het de maand juni of juli is, en als ik de datums doortrek tot waar normaal de 31e moet komen, komt de datum van de volgende maand al. Waar maak ik een fout?
Gelieve uw systeemgegevens in te vullen. Klik HIER voor meer informatie.

Offline knopperke

  • Lid
  • *
  • Berichten: 58
  • Oplossing.be
Re: ivm automatisch aanvullen met datums van die maand op basis van maandnummer
« Reactie #1 Gepost op: 21 augustus 2017, 20:51:59 »
Oplossing gevonden.
Gelieve uw systeemgegevens in te vullen. Klik HIER voor meer informatie.

Offline knopperke

  • Lid
  • *
  • Berichten: 58
  • Oplossing.be
Re: ivm automatisch aanvullen met datums van die maand op basis van maandnummer
« Reactie #2 Gepost op: 21 augustus 2017, 20:54:51 »
Wie mij toch kan helpen, oplossing toch welkom vrees ik.
Gelieve uw systeemgegevens in te vullen. Klik HIER voor meer informatie.

Offline RedHead

  • Ambassadeur
  • *****
  • Berichten: 1.648
  • Geslacht: Man
  • Met Excel lukt 't wel.... (toch???)
Re: ivm automatisch aanvullen met datums van die maand op basis van maandnummer
« Reactie #3 Gepost op: 21 augustus 2017, 21:14:56 »
Voor cel B6 en dan door kopiŽren naar het einde...

[English] =IF(TEXT(MAX($B$5:B5)+1;"mmmm")<>$A$1;"";MAX($B$5:B5)+1)

[Dutch] =ALS(TEKST(MAX($B$5:B5)+1;"mmmm")<>$A$1;"";MAX($B$5:B5)+1)
______________________________

Groet, Leo

Offline RedHead

  • Ambassadeur
  • *****
  • Berichten: 1.648
  • Geslacht: Man
  • Met Excel lukt 't wel.... (toch???)
Re: ivm automatisch aanvullen met datums van die maand op basis van maandnummer
« Reactie #4 Gepost op: 21 augustus 2017, 21:17:00 »
Hmmm..... iets simpeler kan natuurlijk ook in dit geval...  :'(

[English] =IF(TEXT(B5+1;"mmmm")<>$A$1;"";B5+1)

[Dutch] =ALS(TEKST(B5+1;"mmmm")<>$A$1;"";B5+1)
______________________________

Groet, Leo

Offline Biebabeloeba

  • Lid
  • *
  • Berichten: 10
Re: ivm automatisch aanvullen met datums van die maand op basis van maandnummer
« Reactie #5 Gepost op: 22 augustus 2017, 12:42:16 »
Dag RedHad, Bedankt voor de hulp. Ik denk dat de eerste formule (de uitgebreidere) het best is. De simpelere heeft een WAARDE-fout bij de datums 30 en 31e van de maand, als ik eerst februari gekozen heb, en daarna terug mei, de eerste niet. Ik zal de uitgebreidere formule gebruiken.

 


www.combell.com