*

Help!

Problemen met uw pc? De vrijwilligers van oplossing.be zoeken gratis met u mee! 8)

Meer weten over Oplossing.be?

Hoe stel ik een vraag?

Recent

Auteur Topic: Lege cellen verwijzen naar ander tabblad  (gelezen 2135 keer)

Offline Oddhunter

  • Lid
  • *
  • Berichten: 15
  • Geslacht: Man
  • Oplossing.be
Lege cellen verwijzen naar ander tabblad
« Gepost op: 20 maart 2018, 16:46:40 »
Hoe kan ik er voor zorgen als ik een verwijzing doe van het ene naar het andere tabblad dat lege cellen niet ingevuld worden met 0 ?
Dus ik verwijs een aantal gegevens van rijen van het ene tabblad naar het andere tabblad

=Matchenweekend!D18   <<<<---- deze gegevens komen dus van het tabblad Matchenweekend , maar als deze cellen leeg zijn , had ik graag willen weten hoe ik bij deze verwijzing een formule syntax kan plaatsen dat er voor zorgt dat de cellen dan leeg blijven?

Nu krijg ik dit --->>>>



Terwijl de cellen waarvan ik verwijs gewoon leeg zijn

Offline SoftAid

  • Administrator
  • Ambassadeur
  • *****
  • Berichten: 17.043
  • Geslacht: Man
  • Nobody is perfect, not even me...
Re: Lege cellen verwijzen naar ander tabblad
« Reactie #1 Gepost op: 20 maart 2018, 17:27:43 »
hallo Odhunter,

Welkom op Oplossing.be  :)

Je kan je verwijsformule uitbreiden met een voorwaarde! Als de cel leeg is, geef dan een lege cel als resultaat.

vervang =Matchenweekend!D18 door:
=ALS(Matchenweekend!D18="";"";Matchenweekend!D18)Parameters voor de Functie ALS (Voorwaarde;Als waar;Als Onwaar)
ALS(D18=niets;toon niets;toon D18)

:) SoftAid :)             
« Laatst bewerkt op: 20 maart 2018, 17:32:48 door SoftAid »
Wegens veelvuldig melden van dubbelposten, het posten op verschillende help-fora van dezelfde vraag, zijn de gedragsregels op dit forum aangepast. Dubbelposten dient in de toekomst op voorhand gemeld te worden, met een melding en een link naar het topic op de andere site. De helpers wensen een weinig respect voor de inspanningen die ze doen om mensen te helpen. Je doet jezelf ook een plezier. Door je dubbelposten te melden wordt je vraag op meerdere fora beantwoord.

Offline firmin

  • Ervaren lid
  • ***
  • Berichten: 439
  • Geslacht: Man
  • Excel Specialist
Re: Lege cellen verwijzen naar ander tabblad
« Reactie #2 Gepost op: 20 maart 2018, 17:37:23 »
Oddhunter ,

Klik links boven op de knop "office knop"
klik op "opties voor excel"
klik in de linkse kolom op "geavanceerd"
in de rechtse kolom scroll naar beneden tot "weergaveopties voor dit werkblad"
haal het vinkje weg bij "een nul weergevenin cellen met een nulwaarde"
klik op de knop "OK"

Firmin
PB easynote LE69KB,AMD quad-core,1000GB HDD,AMD Radeon HD8330,8GB DDR3
Windows 10,office 2007
MSE, Internet Explorer 11

Offline Oddhunter

  • Lid
  • *
  • Berichten: 15
  • Geslacht: Man
  • Oplossing.be
Re: Lege cellen verwijzen naar ander tabblad
« Reactie #3 Gepost op: 20 maart 2018, 18:58:22 »
Bedankt voor je reactie Firmin , Dit had ik al geprobeerd , maar uiteindelijk omdat ik deze cellen later nog eens moet kopiŽren naar een ander tabblad om deze te sorteren van klein naar groot , kan ik deze methode niet gebruiken omdat de inhoud hier niet zichtbaar is, maar er uiteindelijk wel is en hij deze dan mee kopiŽert naar de andere cellen , dus de nullen worden wel mee gekopiŽerd , maar toch bedankt ;-)

En SoftAid ,
Jouw methode lijkt me beter te werken want de cellen zijn uiteindelijk wel leeg als ik ze daarna kopiŽer ,
maar nu vroeg ik mij af , ik wil deze voorwaarde bij een andere formule bijvoegen

Hier worden de waarden opgeteld , maar soms heb ik een cel waar niets staat , dus als ik in de ene cel vooraf niets invul zoals een andere gegeven om te voorkomen dat de cellen niet gelijk zijn aan elkaar , deze wel meegeteld worden

zie formule --->>> 

Het is hier dus de bedoeling dat sommige cellen niet op voorhand worden ingevuld en aanzien worden als leeg indien niets ingevuld is

Dit is de normale formule --->>>  =ALS($A$18=P18;1;0)+ALS($A$19=P19;1;0) --->>> ik heb dus bij A17 EN P17(zie formulebalk)  jou syntax bijgevoegd , maar ik denk dat ik iets verkeerd doe , aangezien hij zegt teveel argumenten --->> , of kan dit niet?
« Laatst bewerkt op: 20 maart 2018, 19:26:02 door Oddhunter »

Offline Haije

  • Lid
  • *
  • Berichten: 35
  • Geslacht: Man
  • Oplossing.be
Re: Lege cellen verwijzen naar ander tabblad
« Reactie #4 Gepost op: 20 maart 2018, 19:38:28 »
=ALS($A$17=P17;1;0;"";"")
dit is geen correcte formule

=ALS($A$17=P17,1,0)
is wel correct, maar ik weet niet wat je wilt dat de uitkomst is....

Offline Oddhunter

  • Lid
  • *
  • Berichten: 15
  • Geslacht: Man
  • Oplossing.be
Re: Lege cellen verwijzen naar ander tabblad
« Reactie #5 Gepost op: 20 maart 2018, 19:53:48 »
Ik zal het proberen uit te leggen in een ander voorbeeld

Offline Oddhunter

  • Lid
  • *
  • Berichten: 15
  • Geslacht: Man
  • Oplossing.be
Re: Lege cellen verwijzen naar ander tabblad
« Reactie #6 Gepost op: 20 maart 2018, 20:10:52 »


« Laatst bewerkt op: 20 maart 2018, 20:30:27 door Oddhunter »

Offline SoftAid

  • Administrator
  • Ambassadeur
  • *****
  • Berichten: 17.043
  • Geslacht: Man
  • Nobody is perfect, not even me...
Re: Lege cellen verwijzen naar ander tabblad
« Reactie #7 Gepost op: 20 maart 2018, 23:27:12 »
Hallo Oddhunter,

in de eerste ALS() -functie heb je inderdaad te veel argumenten gebruikt.
ALS() heeft maar 3 elementen, de voorwaarde, resultaat als WAAR, resultaat als ONWAAR.
Jij het in de eerste ALS() 5 argumenten gebruikt:
=ALS($A$17=P17;1;0;"","")
Probeer eens met deze code:
=ALS(OF(A17="";P17="");0;ALS(A17=P17;1;0))
:) SoftAid :)             
Wegens veelvuldig melden van dubbelposten, het posten op verschillende help-fora van dezelfde vraag, zijn de gedragsregels op dit forum aangepast. Dubbelposten dient in de toekomst op voorhand gemeld te worden, met een melding en een link naar het topic op de andere site. De helpers wensen een weinig respect voor de inspanningen die ze doen om mensen te helpen. Je doet jezelf ook een plezier. Door je dubbelposten te melden wordt je vraag op meerdere fora beantwoord.

Offline plongske

  • Ervaren lid
  • ***
  • Berichten: 257
  • Geslacht: Man
  • Oplossing.be
Re: Lege cellen verwijzen naar ander tabblad
« Reactie #8 Gepost op: 20 maart 2018, 23:27:45 »
Plaatst even het bestandje wat je nu hebt, dan kunnen we zelf even testen.
in plv al die ALS formules bestaan er tal van functies die waarschijnlijk lijden naar de oplossing. Ik denk bijvoorbeeld aan SOM.ALS;SOMMEN.ALS; AANTAL.ALS;AANTALLEN.ALS en  SOMPRODUCT.
Groeten plongske

Offline Oddhunter

  • Lid
  • *
  • Berichten: 15
  • Geslacht: Man
  • Oplossing.be
Re: Lege cellen verwijzen naar ander tabblad
« Reactie #9 Gepost op: 21 maart 2018, 00:16:40 »
Hartelijk dank  voor de oplossing  \į/, deze formule lijkt wel te werken, ik heb het even getest , zie foto --->>


Offline Oddhunter

  • Lid
  • *
  • Berichten: 15
  • Geslacht: Man
  • Oplossing.be
Re: Lege cellen niet optellen bij totaal
« Reactie #10 Gepost op: 21 maart 2018, 00:21:15 »
Hartelijk dank  voor de oplossing  \į/, deze formule lijkt wel te werken, ik heb het even getest , zie foto --->>



Offline plongske

  • Ervaren lid
  • ***
  • Berichten: 257
  • Geslacht: Man
  • Oplossing.be
Re: Lege cellen verwijzen naar ander tabblad
« Reactie #11 Gepost op: 21 maart 2018, 00:36:40 »
Goed dat je tevreden bent met de geboden oplossing. \į/
Toch maar bij de volgende vraag een excel bestandje toevoegen ipv een plaatje
Het is hier toch een exel forum en geen photoshop forum ;)
Groeten plongske

Offline Oddhunter

  • Lid
  • *
  • Berichten: 15
  • Geslacht: Man
  • Oplossing.be
Re: Lege cellen verwijzen naar ander tabblad
« Reactie #12 Gepost op: 21 maart 2018, 00:46:08 »
Ok, zal er aan denken , maar de sheet is niet helemaal klaar , was een testje , de oplossing staat onder germany 2 vanaf rij 139  :)


Offline plongske

  • Ervaren lid
  • ***
  • Berichten: 257
  • Geslacht: Man
  • Oplossing.be
Re: Lege cellen verwijzen naar ander tabblad
« Reactie #13 Gepost op: 21 maart 2018, 10:39:23 »
Als ik het goed begrijp wordt er in kolom A enkel een x geplaatst als de uitslag een draw is en de voorspelling van Score een draw is?
dan kan je misschien volgende formule gebruiken.
=AANTAL.ALS(P139:P147;"x")-AANTAL.ALS(A139:A147;"x")
Groeten plongske

Offline Oddhunter

  • Lid
  • *
  • Berichten: 15
  • Geslacht: Man
  • Oplossing.be
Re: Lege cellen verwijzen naar ander tabblad
« Reactie #14 Gepost op: 22 maart 2018, 13:14:40 »
Deze formule werkt niet bij mij , hij zou cel 29P nu toch een 3 moeten weergeven want heb in kolom A17 A18 A19 EN P17 P18 EN P19 een X gezet , maar hij geeft 0  zie sheet --->>>

 


www.combell.com