Help!

PC-Problemen?
De vrijwilligers van Oplossing.be zoeken gratis met u mee!

Hulp bij posten

Recente topics

Auteur Topic: 2 lijsten met namen vergelijken, namen zijn niet identiek gespeld  (gelezen 6510 keer)

0 leden en 1 gast bekijken dit topic.

Offline cow18

  • Excel-Expert
  • Volledig lid
  • *****
  • Berichten: 249
  • Geslacht: Man
  • Oplossing.be
Re: 2 lijsten met namen vergelijken, namen zijn niet identiek gespeld
« Reactie #15 Gepost op: 14 februari 2020, 11:22:55 »
Dat lijkt me ook !
Als je een excel of een tekstbestand (csv) van de bank krijgt, dan staan daar, netjes over een 20-tal kolommen verspreid, een bult zaken waarmee je al 95% van de vraag van TS beantwoordt.

Offline ptm

  • Lid
  • *
  • Berichten: 10
  • Oplossing.be
Re: 2 lijsten met namen vergelijken, namen zijn niet identiek gespeld
« Reactie #16 Gepost op: 14 februari 2020, 12:23:18 »
Nogmaals het zijn telkens totaal andere lijsten die niets met elkaar te zien hebben.
Anders was een database makkelijker geweest.
Mét de combinatie van jullie oplossingen ben ik al zeer tevreden.
Vanavond probeer ik om te zoeken vanaf rechts en tussen de eerste en tweede spatie.
Alvast bedankt voor jullie oplossingen.

Offline ptm

  • Lid
  • *
  • Berichten: 10
  • Oplossing.be
Re: 2 lijsten met namen vergelijken, namen zijn niet identiek gespeld
« Reactie #17 Gepost op: 14 februari 2020, 22:18:56 »
Zoals ik al gevreesd had verdrink ik in de voorbeelden van de google syntaxis voorbeelden.
Ik kan die formule blijkbaar niet lezen in mensentaal.
Ik had gehoopt met links te vervangen door rechts dat het verticaal zoeken met het laatste woord zou gebeuren (zie bijlage).
=ALS.FOUT(VERT.ZOEKEN((ALS.FOUT(LINKS(B2;VIND.ALLES(" ";B2)-1);B2))&"*";leverancierslijst!B:B;1;0);"")
=ALS.FOUT(VERT.ZOEKEN((ALS.FOUT(RECHTS(B2;VIND.ALLES(" ";B2)-1);B2))&"*";leverancierslijst!B:B;1;0);"")
Als jullie het nog zien zitten of iemand anders die cow18 en pitufo wil ontlasten?

Offline ptm

  • Lid
  • *
  • Berichten: 10
  • Oplossing.be
Re: 2 lijsten met namen vergelijken, namen zijn niet identiek gespeld
« Reactie #18 Gepost op: 15 februari 2020, 10:24:57 »
Op https://www.helpmij.nl/forum/showthread.php/951685-2-lijsten-met-namen-vergelijken-namen-zijn-niet-identiek-gespeld?p=6220410 kreeg ik van roeljongman de tip die blijkbaar het huisnummer linkt aan de BMI ;-)
de Fuzzy lookup addin van microsoft
https://www.microsoft.com/en-us/down....aspx?id=15011
Iedereen bedankt voor jullie bijdrage!
Mocht toch iemand de formule van ptufo kunnen vertalen en de fout in het zoeken vanaf rechts tonen dan kan ik die eventueel nog gebruiken in andere gevallen of indien Fuzzy mij in de steek laat ...

Offline pitufo

  • Excel-Expert
  • Ambassadeur
  • *****
  • Berichten: 1.177
  • Geslacht: Man
Re: 2 lijsten met namen vergelijken, namen zijn niet identiek gespeld
« Reactie #19 Gepost op: 15 februari 2020, 10:40:34 »
Hallo,

Het gebeurt uiterst zelden, maar ik kreeg toch wel nog een ingeving, zeker...
Neen neen, niet om alles op te lossen (over de onmogelijkheid bestaat al lang eensgezindheid), maar als in de betaallijst één exacte schrijfwijze voorkomt zijn ook de andere met zekerheid te vinden (zie de kolommen D tot F in de bijlage). Het lijkt mij aangewezen om eerst en vooral met deze werkwijze alle zuivere matches te zoeken, en pas in een volgende fase allerlei methodes te gebruiken voor de resterende.
"De computer doet wel degelijk wat je hem vraagt,
 maar NIET wat je DENKT dat je hem vraagt"

Offline pitufo

  • Excel-Expert
  • Ambassadeur
  • *****
  • Berichten: 1.177
  • Geslacht: Man
Re: 2 lijsten met namen vergelijken, namen zijn niet identiek gespeld
« Reactie #20 Gepost op: 15 februari 2020, 10:51:18 »
Ondertussen ook je volgende post gezien, en ik heb niets tegen het gebruik van Fuzzy, maar wél de bedenking dat je er niet blindelings mag op vertrouwen. Als het over hele lange lijsten gaat waarin zowat alles mogelijk is zal hij eventueel nog altijd evenveel resultaten geven, maar je zal ze toch nog moeten verifiëren, dus mijn advies (voor wat het waard is) blijft: eerst de methode uit mijn vorige post, dan Fuzzy, en daarna eventueel nog wat andere methodes.
"De computer doet wel degelijk wat je hem vraagt,
 maar NIET wat je DENKT dat je hem vraagt"

Offline pitufo

  • Excel-Expert
  • Ambassadeur
  • *****
  • Berichten: 1.177
  • Geslacht: Man
Re: 2 lijsten met namen vergelijken, namen zijn niet identiek gespeld
« Reactie #21 Gepost op: 15 februari 2020, 11:34:13 »
Lap, 3 pitufo-reacties op rij... (vergeet de vorige niet te lezen!)

Citaat
Mocht toch iemand de formule van ptufo kunnen vertalen en de fout in het zoeken vanaf rechts tonen

Mijn zoeken vanaf links kan je, zoals je zelf hebt ondervonden, inderdaad geenszins 'vertalen' naar zoeken vanaf rechts.
Wat (uiteraard) niet wil zeggen dat het niet te doen is, alleen net een tikkeltje lastiger. In de huidige bijlage heb ik het met kolommen G tot J gedaan. Die zou je nog kunnen samenvoegen maar dat zou enkel de lees- en begrijpbaarheid nadelig beïnvloeden.

Als je ergens vanaf een vrij te kiezen spatie een 'woord' wil vinden kan je hier ook iets mee. Even zelf proberen dan?
"De computer doet wel degelijk wat je hem vraagt,
 maar NIET wat je DENKT dat je hem vraagt"

Offline ptm

  • Lid
  • *
  • Berichten: 10
  • Oplossing.be
Re: 2 lijsten met namen vergelijken, namen zijn niet identiek gespeld
« Reactie #22 Gepost op: 22 februari 2020, 13:39:34 »
Je moet er maar opkomen  \o/
Met links en rechts zoeken in combinatie met Fuzzy Lookup en de bijdragen van Cow18 ben ik al ferm geholpen.
Bedankt iedereen voor het brainwork  _/-\o_ _/-\o_

Offline cow18

  • Excel-Expert
  • Volledig lid
  • *****
  • Berichten: 249
  • Geslacht: Man
  • Oplossing.be
Re: 2 lijsten met namen vergelijken, namen zijn niet identiek gespeld
« Reactie #23 Gepost op: 23 februari 2020, 09:44:43 »
bedankt voor de terugkoppeling en veel succes met het bekomen resultaat

 


www.combell.com