Help!

PC-Problemen?
De vrijwilligers van Oplossing.be zoeken gratis met u mee!

Hulp bij posten

Recente topics

Auteur Topic: ALS functie met meerdere voorwaarden  (gelezen 23039 keer)

0 leden en 1 gast bekijken dit topic.

Offline rdcoster

  • Ervaren lid
  • ***
  • Berichten: 274
  • Geslacht: Man
  • Oplossing.be
ALS functie met meerdere voorwaarden
« Gepost op: 22 december 2019, 10:07:01 »
Bestaat er in Excel zoiets met een ALS functie maar die aan meerdere voorwaarden moet voldoen.
Ik bedoel niet de geneste ALS.

Wel zoiets:
ALS voorwaarde1 EN voorwaarde2 voldaan zijn geef dan WAAR; ONWAAR
Windows 10
Excel 2013

Offline Georgyboy

  • Ervaren lid
  • ***
  • Berichten: 317
  • Geslacht: Man
  • Oplossing.be
Re: ALS functie met meerdere voorwaarden
« Reactie #1 Gepost op: 22 december 2019, 10:39:27 »
Enkele voorbeelden ?

Gecombineerde logische tests gebruiken
Een gecombineerde logische test is een combinatie van verschillende logische tests. U kunt daarbij de operatoren OF en EN gebruiken.
OF gebruiken
=ALS(OF(A1>D1;A2>D2);D4;D5)
waarbij:
OF(A1>D1;A2>D2): de gecombineerde logische test. Als A1 groter is als D1 OF als A2 groter is dan D2, zal deze waar zijn. Indien niet zal deze onwaar zijn.
D4: waarde als waar
D5: waarde als onwaar
EN gebruiken
=ALS(EN(A1>D1;A2>D2;A3>D3);D4;D5)
waarbij:
EN(A1>D1;A2>D2;A3>D3): de gecombineerde logische test. Als A1 groter is als D1 EN als A2 groter is dan D2 EN als A3 groter is als D3, zal deze waar zijn. Indien niet zal deze onwaar zijn.
Let op! Het is dus mogelijk om meer dan 2 verschillende logische tests te combineren
D4: waarde als waar
D5: waarde als onwaar
geneste EN/OF
=ALS(OF(A1>B1;EN(A2>B2;A3>B3));D4;D5)
waarbij:
OF(A1>B1;EN(A2>B2;A3>B3)): de geneste gecombineerde logische test. Als A1 groter is als D1 OF als A2 groter is dan D2 EN als A3 groter is als D3, zal deze waar zijn. Indien niet zal deze onwaar zijn.
Let op! Eerst wordt er gekeken of de geneste logische test, hier EN(A2>B2;A3>B3), waar of onwaar is en dan berekent men of de algemene logische test, de OF-test, waar of onwaar is.
D4: waarde als waar
D5: waarde als onwaar

Offline rdcoster

  • Ervaren lid
  • ***
  • Berichten: 274
  • Geslacht: Man
  • Oplossing.be
Re: ALS functie met meerdere voorwaarden
« Reactie #2 Gepost op: 22 december 2019, 17:19:22 »
Ik heb een aantal tests gedaan maar ik geraak niet uit volgende fout - zie bijlage
Windows 10
Excel 2013

Offline emields

  • Ervaren lid
  • ***
  • Berichten: 257
  • Geslacht: Man
  • Oplossing.be
Re: ALS functie met meerdere voorwaarden
« Reactie #3 Gepost op: 22 december 2019, 18:04:06 »
dit is een mogelijkheid, maar hoe kunnen wij weten wat aanzien wordt voor waar en wat onwaar is?

 


www.combell.com