Help!

PC-Problemen?
De vrijwilligers van Oplossing.be zoeken gratis met u mee!

Hulp bij posten

Recente topics

Auteur Topic: cijfersom in exel  (gelezen 1185 keer)

0 leden en 1 gast bekijken dit topic.

Offline prudent123

  • Lid
  • *
  • Berichten: 20
  • Oplossing.be
cijfersom in exel
« Gepost op: 12 november 2020, 17:29:51 »
ik zoek een formule in Exel om de cijfersom van een getal te bepalen.
bv 1983 =1+9+8+3 =21

Offline pitufo

  • Excel-Expert
  • Ambassadeur
  • *****
  • Berichten: 1.260
  • Geslacht: Man
Re: cijfersom in exel
« Reactie #1 Gepost op: 13 november 2020, 08:55:50 »
Hallo prudent123,

Welkom op oplossing.be.
Ik lees het niet in je post maar vermoedelijk zoek je niet enkel, maar heb je ook een vraag om een oplossing...

Uit je nogal summiere uitleg blijkt ook niet uit hoeveel cijfers het getal maximaal kan bestaan. Hierbij een simpele manier met 10 hulpkolommen (wat betekent dat het tot 10 cijfers mag gaan, en k dat je het zelf kan vermeerderen of verminderen).

"De computer doet wel degelijk wat je hem vraagt,
 maar NIET wat je DENKT dat je hem vraagt"

Offline prudent123

  • Lid
  • *
  • Berichten: 20
  • Oplossing.be
Re: cijfersom in exel
« Reactie #2 Gepost op: 14 november 2020, 10:56:00 »
dank u wel voor uw uitleg.

Offline Veerj

  • Nieuw lid
  • Berichten: 7
Re: cijfersom in exel
« Reactie #3 Gepost op: 30 december 2020, 19:39:10 »
Met 1 matrixformule. Afsluiten met control shift enter

=SOMPRODUCT(ALS.FOUT(--DEEL(A1;RIJ($1:$10);1);0))

Offline RedHead

  • Excel-Expert
  • Ambassadeur
  • *****
  • Berichten: 2.029
  • Geslacht: Man
  • Met Excel lukt 't wel.... (toch???)
Re: cijfersom in exel
« Reactie #4 Gepost op: 30 december 2020, 20:07:56 »
Cijfersom? Geocache puzzels?
______________________________

Groet, Leo

Offline Warme bakkertje

  • Lid
  • *
  • Berichten: 51
  • Geslacht: Man
Re: cijfersom in exel
« Reactie #5 Gepost op: 31 december 2020, 18:41:23 »
Enkele samengevat in een bestandje.

De bovenste 3 kunnen vreemde tekens in de reeks aan. (alpha karakters of negatief teken)
Windows 10 Home   NLD 64bit

Microsoft Office Professional Plus 2016 US

Offline Veerj

  • Nieuw lid
  • Berichten: 7
Re: cijfersom in exel
« Reactie #6 Gepost op: 02 januari 2021, 13:21:25 »
Nog 1 voor office 365

=SOM(--FILTER(DEEL(A1;RIJ($1:$10);1);DEEL(A1;RIJ($1:$10);1)<>""))

UDF:
Function jv(cell)
 For i = 1 To Len(cell)
    a = a + (--Mid(cell, i, 1))
 Next
 jv = a
End Function

Invoeren als =jv(A1)
« Laatst bewerkt op: 02 januari 2021, 18:08:43 door Veerj »

 


www.combell.com