Help!

PC-Problemen?
De vrijwilligers van Oplossing.be zoeken gratis met u mee!

Hulp bij posten

Recente topics

Auteur Topic: EK2008  (gelezen 38799 keer)

0 leden en 1 gast bekijken dit topic.

Offline flipper52

  • Ervaren lid
  • ***
  • Berichten: 294
  • Geslacht: Man
EK2008
« Gepost op: 09 december 2007, 15:29:17 »
Dit is een bericht aan Erik en Danny, of jullie dit eens willen bekijken en jullie mening erover zeggen.
Zoals je wel weet, als je in de cel met een ploeg gaat staan komt er een keuzelijst te voorschijn, de rest spreekt voor zich.
Natuurlijk heb ik ťťn vraag, als ik een score invoer, hoe komt het dat alles dan traag werkt ?

Groetjes Rudy
Standaard emailprogramma: Microsoft Outlook 2010
Standaard Operating System: Windows 7 Home 64-bits
Standaard Browser:Internet Explorer 9
Microsoft Office 2010

Offline danny147

  • Oplosser
  • ****
  • Berichten: 564
  • Geslacht: Man
  • Lotto, de sleutel tot het succes.
    • Lotto, de sleutel tot het succes
Re: EK2008
« Reactie #1 Gepost op: 09 december 2007, 16:28:36 »
Beste Flipper.  ;)

Heb er eens na gekeken en bij mij doet hij het binnen de seconde.
Misschien door de vele indexen en vergelijkingen die er in staan ?
Wel goed in elkaar gestoken, proficiat !

Misschien dat Erik of Leo hier een antwoord op hebben.

Groetjes Danny.  :)
Windows 10 Home   NLD 64bit
Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz 1200
SAMSUNG_NP1234567890
Intel(R) HD Graphics 4000 2112MB -
Realtek High Definition Audio
Nr: 1 Model: Hitachi HTS727575A9E364
C:\ NTFS 670,11GB 494,48GB 8 080MB
AV: Trend Micro Maximum Security

Offline RedHead

  • Excel-Expert
  • Ambassadeur
  • *****
  • Berichten: 1.951
  • Geslacht: Man
  • Met Excel lukt 't wel.... (toch???)
Re: EK2008
« Reactie #2 Gepost op: 09 december 2007, 21:40:11 »
Flipper52, Ik denk dat Danny147 gelijk heeft. Je hebt inderdaad hele mooie complexe formules gemaakt. En in het midden bij de groepen zelfs matrixformules met de Indirect-functie. Dit zijn behoorlijk zware berekeningen voor Excel. Toch vind ik persoonlijk de rekentijd volledig acceptabel.

Ik denk denk dat je met dit mooie stuk werk (dat zijn vast vele vrije uren geweest! ;)) een hoop voetballiefhebbers blij kan maken.

Groet, Leo
______________________________

Groet, Leo

Offline Erik Van Geit

  • Excel-Expert
  • Ervaren lid
  • *****
  • Berichten: 306
  • Geslacht: Man
Re: EK2008
« Reactie #3 Gepost op: 09 december 2007, 21:57:27 »
Dag, Rudy,

Dit gaat voor mij ook traag. Als het voor Danny en Leo wel snel werkt, ligt het wellicht gewoon aan de snelheid van je systeem en uiteraard ook welke processen er allemaal lopen. Excel 2007 is doorgaans ook (ruim) trager dan de vorige versies. (ik heb XP)

In principe zou volgende code sneller moeten werken.
Private Sub CommandButton1_Click()
Dim lVolgendeRij As Long
Dim AppCalcSet As Long

lVolgendeRij = Cells(Rows.Count, 1).End(xlUp).Row + 1

    With Application
    AppCalcSet = .Calculation
    .Calculation = xlCalculationManual
    ' Invullen van de cellen
    Cells(lVolgendeRij, 2).Value = Cells(8, 11).Text
    Cells(lVolgendeRij, 3).Value = Cells(8, 16).Text
    Cells(lVolgendeRij, 4).Value = Cells(8, 19).Text
    Cells(lVolgendeRij, 5).Value = Cells(8, 21).Text
    Cells(lVolgendeRij, 1).Value = Cells(6, 16).Text
    .Calculation = AppCalcSet
    End With

End Sub
"berekenen" (zie Extra/Opties) wordt op handmatig gezet en op het einde weer "teruggezet" zoals het ingesteld was. (als "berekenen" reeds handmatig was, zal dat ook zo blijven na de macro, maar bij jou staat dat wellicht op automatisch)

Als "berekenen" op automatisch staat, spendeert je macro bij elke celwijziging tijd om de hele boel opnieuw uit te rekenen.

Ik vrees echter dat het niet veel zal helpen; bij mij blijft ie ook traag rekenen na deze operatie.

1083 formules lijkt me ook veel voor deze taak, maar misschien onderschat ik het. 'k Heb een lijst van alle formules gemaakt met Table-It. Handig om even een blik te werpen op de zaak.
Volgende formules op "Blad2" zijn alleszins mogelijke boosdoeners. Misschien heb ik er per ongeluk te veel uit de Table-It lijst gewist en zijn er nog meer.
ADRES     FORMULE (1ste cel)
Q2:Q5     =SOM.ALS(B:B;P2;H:H)+SOM.ALS(E:E;P2;H:H)
Q8:Q11    =SOM.ALS(B:B;P8;H:H)+SOM.ALS(E:E;P8;H:H)
Q14:Q17   =SOM.ALS(B:B;P14;H:H)+SOM.ALS(E:E;P14;H:H)
Q20:Q23   =SOM.ALS(B:B;P20;H:H)+SOM.ALS(E:E;P20;H:H)
R2:R5     =SOM.ALS(B:B;P2;I:I)+SOM.ALS(E:E;P2;J:J)
R8:R11    =SOM.ALS(B:B;P8;I:I)+SOM.ALS(E:E;P8;J:J)
R14:R17   =SOM.ALS(B:B;P14;I:I)+SOM.ALS(E:E;P14;J:J)
R20:R23   =SOM.ALS(B:B;P20;I:I)+SOM.ALS(E:E;P20;J:J)
S2:S5     =SOM.ALS(B:B;P2;K:K)+SOM.ALS(E:E;P2;K:K)
S8:S11    =SOM.ALS(B:B;P8;K:K)+SOM.ALS(E:E;P8;K:K)
S14:S17   =SOM.ALS(B:B;P14;K:K)+SOM.ALS(E:E;P14;K:K)
S20:S23   =SOM.ALS(B:B;P20;K:K)+SOM.ALS(E:E;P20;K:K)
X2:X5     =SOM.ALS(B:B;P2;D:D)+SOM.ALS(E:E;P2;C:C)
X8:X11    =SOM.ALS(B:B;P8;D:D)+SOM.ALS(E:E;P8;C:C)
X14:X17   =SOM.ALS(B:B;P14;D:D)+SOM.ALS(E:E;P14;C:C)
X20:X23   =SOM.ALS(B:B;P20;D:D)+SOM.ALS(E:E;P20;C:C)
Z2:Z5     =SOM.ALS(B:B;P2;C:C)
Z8:Z11    =SOM.ALS(B:B;P8;C:C)
Z14:Z17   =SOM.ALS(B:B;P14;C:C)
Z20:Z23   =SOM.ALS(B:B;P20;C:C)
AA2:AA5   =SOM.ALS(E:E;P2;D:D)
AA8:AA11  =SOM.ALS(E:E;P8;D:D)
AA14:AA17 =SOM.ALS(E:E;P14;D:D)
AA20:AA23 =SOM.ALS(E:E;P20;D:D)
[Table-It] version 07 by Erik Van Geit
Al deze formules verwijzen naar volledige kolommen, wat de zaak aanzienlijk vertraagt, al zijn het er niet zo veel.

Als je bij het ontwerpen al heel veel zaken hebt verschoven, verwijderd, gecopieerd ... dan is het ook mogelijk dat er een zekere "corruptie" in je werkboek is opgetreden. Ja, mensen, Excel verteerd eigenlijk niet zo goed al dat "geschuif". Daarom kan het nuttig zijn je werkboek even te hermaken vanaf nul. Ik ga dat hier nu niet helemaal uitleggen, maar vele mensen zijn al geholpen met mijn topic REBUILD your workbook. 't Is in het Engels.

beste groeten,
Erik

EDIT
Vandaag zal de link niet werken, want ze zijn daar aan het "verbouwen".
« Laatst bewerkt op: 09 december 2007, 22:04:04 door Erik Van Geit »

Offline popipipo

  • Excel-Expert
  • Ervaren lid
  • *****
  • Berichten: 258
Re: EK2008
« Reactie #4 Gepost op: 10 december 2007, 00:16:59 »
Hallo Rudy

Zoals al eerder is vermeld ziet het er zeer goed en weloverwogen uit.
Ik doe het je absoluut niet na.
Echter, als in een poule 2 teams boven aan gelijk eindigen laat jij het doelsaldo beslissen wie nr 1 of nr 2 wordt.
De UEFA regel is echter dat de onderlinge wedstrijd eerst geldt en daarna pas het doelsaldo.

Ik ben zelf ook bezig geweest en liep daar ook tegen aan.
Via enkele tussen berekeningen ben ik er wel uit gekomen.
Bekijk het resultaat maar eens


Willem
Willem
Hoe meer je weet hoe meer je vergeet.
Hoe meer je vergeet hoe minder je weet.
Hoe minder je weet hoe minder je vergeet.
Hoe minder je vergeet hoe meer je weet.

Offline flipper52

  • Ervaren lid
  • ***
  • Berichten: 294
  • Geslacht: Man
Re: EK2008
« Reactie #5 Gepost op: 11 december 2007, 23:05:07 »
Ben ondertussen bezig met een ander exemplaar, nog even geduld A.U.B.
Popipipo, in elk geval bedankt voor dat bestand, heb het eens grondig bekeken, heel goed gemaakt.

Groetjes, Flipper52
« Laatst bewerkt op: 11 december 2007, 23:07:09 door flipper52 »
Standaard emailprogramma: Microsoft Outlook 2010
Standaard Operating System: Windows 7 Home 64-bits
Standaard Browser:Internet Explorer 9
Microsoft Office 2010

Offline flipper52

  • Ervaren lid
  • ***
  • Berichten: 294
  • Geslacht: Man
Re: EK2008
« Reactie #6 Gepost op: 12 december 2007, 13:00:07 »
Zoals eerder vermeld, hier mijn nieuw exemplaar,hopelijk klopt het nu wel Popipipo.
In elk geval zijn jullie drie,Danny,Erik en Popipipo, hartelijk bedankt voor de nuttige tips.
Het enige wat ik niet kan verbeteren is de snelheid.
Hopelijk vinden jullie dit even knap.

Groetjes Rudy
Standaard emailprogramma: Microsoft Outlook 2010
Standaard Operating System: Windows 7 Home 64-bits
Standaard Browser:Internet Explorer 9
Microsoft Office 2010

Offline dirktimm

  • Lid
  • *
  • Berichten: 42
  • Oplossing.be
Re: EK2008
« Reactie #7 Gepost op: 12 december 2007, 14:27:21 »
Hallo flipper,

Een hele mooie poule met fraaie oplossingen. Ik ga hier nog een hoop van leren. Ik heb in mijn poule alleen gebruik gemaakt van de simpele functie's Rang, Somals en de vele ALS. Maar het werkt ook. Als ik een paar standen invul dan gaan er in jouw poule andere landen door dan in mijn poule. Ik denk dat de regels van de UEFA anders zijn dan die jij hebt gebruikt.
Vul b.v de volgende standen in groep A in. 1 - 0, 1 - 0, 1 - 2, 1 - 2, 1 -0 en nogmaals 1 - 0  dan gaan in jouw poule Zwitserland als winnaar door en Turkije als 2e Dat is volgens mij niet juist. Turkije is winnaar van poule A en Zwitserland eindigt als 2e. Of ik begrijp het helemaal verkeerd.

Als ik het goed zie, dan staat het 1e coefficient dat je gebruikt in kolom AJ van blad2. Deze coefficient is niet juist.  Volgens de regels van de UEFA bestaat het 1e coefficient alleen maar uit het aantal behaalde punten. en vervolgens enz, enz, Zie UEFA regels

Groet

Dirk   
Gelieve uw systeemgegevens in te vullen. Klik HIER voor meer informatie.

Offline flipper52

  • Ervaren lid
  • ***
  • Berichten: 294
  • Geslacht: Man
Re: EK2008
« Reactie #8 Gepost op: 12 december 2007, 14:35:34 »
dank u voorde tip, zal me eens gaan verdiepen in de UEFA regels

Flipper52
Standaard emailprogramma: Microsoft Outlook 2010
Standaard Operating System: Windows 7 Home 64-bits
Standaard Browser:Internet Explorer 9
Microsoft Office 2010

Offline dirktimm

  • Lid
  • *
  • Berichten: 42
  • Oplossing.be
Re: EK2008
« Reactie #9 Gepost op: 12 december 2007, 14:42:46 »
Gelieve uw systeemgegevens in te vullen. Klik HIER voor meer informatie.

Offline dirktimm

  • Lid
  • *
  • Berichten: 42
  • Oplossing.be
Re: EK2008
« Reactie #10 Gepost op: 12 december 2007, 14:58:12 »
Hallo Willem,

In jouw poule gaat het volgens mij ook niet goed. Bij dezelfde standen gaat Zwitserland als winnaar door en Portugal als 2e. Leuk, deze verschillende uitkomsten.

Groet

Dirk
« Laatst bewerkt op: 12 december 2007, 21:24:19 door dirktimm »
Gelieve uw systeemgegevens in te vullen. Klik HIER voor meer informatie.

Offline flipper52

  • Ervaren lid
  • ***
  • Berichten: 294
  • Geslacht: Man
Re: EK2008
« Reactie #11 Gepost op: 12 december 2007, 15:38:25 »
is er iemand die kan aanduiden in mijn poule wat ik exact verkeerd doe met de berekeningen. Dit dan wel in het bestand EURO2008 (3).
Dank bij voorbaat

Groetjes Rudy
Standaard emailprogramma: Microsoft Outlook 2010
Standaard Operating System: Windows 7 Home 64-bits
Standaard Browser:Internet Explorer 9
Microsoft Office 2010

Offline popipipo

  • Excel-Expert
  • Ervaren lid
  • *****
  • Berichten: 258
Re: EK2008
« Reactie #12 Gepost op: 12 december 2007, 20:31:09 »
Hallo dirktimm


Zwitserland     - TsjechiŽ   0 - 1
Portugal          - Turkije     3 - 0
TsjechiŽ           - Portugal  0 - 3
Zwitserland     - Turkije     1 - 0
Turkije             - TsjechiŽ   1 - 1
Zwitserland     - Portugal   1 - 0

Als ik dit invul hebben Zwitserland en Portugal beide 6 punten Het doelsaldo van Portugal is beter, maar Zwitserland heeft van Portugal gewonnen dus Zwitserland staat nr 1 Portugal nr 2.

In mijn programma op blad :STAND in kolom BM Zwitserland en Portugal selecteren dan zie je wel de juiste stand in de kolommen FG tm FM


In jou voorbeeld hebben 3 ploegen 6 punten.
Dan heb ik de regel van de uefa zo geÔnterpreteerd dat de wedstrijd tegen TsjechiŽ niet mee telt en dan komen alle 3 ploegen exact gelijk uit wat punten, saldo, voor- en tegendoelpunten.
 
Hoe de uefa hier mee omgaat weet even ik niet
 
Willem
« Laatst bewerkt op: 12 december 2007, 20:40:23 door popipipo »
Willem
Hoe meer je weet hoe meer je vergeet.
Hoe meer je vergeet hoe minder je weet.
Hoe minder je weet hoe minder je vergeet.
Hoe minder je vergeet hoe meer je weet.

Offline dirktimm

  • Lid
  • *
  • Berichten: 42
  • Oplossing.be
Re: EK2008
« Reactie #13 Gepost op: 12 december 2007, 21:23:29 »
Hallo Willem,

Met de standen die je nu opgeeft ben ik helemaal eens wie er doorgaat. Ik heb echter de standen zoals ik die gebruikt heb in de poule van Flipper ook in jouw poule gebruikt. En dan gaan ook Zwitserland en Portugal over. Volgens mij is het dan niet juist.
Bovendien ga je in kolom BA bij de berekening er 0,1 bij eerste optellen en 0,2 bij de tweede enz. Hier ga je de boel voor het lapje houden. Ik begrijp wel waarom, maar het is natuurlijk geen UEFA regel en dus niet correct. Ik zal morgen mijn idee hoe het wel moet in een document zetten. Eerst nu naar PSV kijken.

Groet

Dirk 
Gelieve uw systeemgegevens in te vullen. Klik HIER voor meer informatie.

Offline popipipo

  • Excel-Expert
  • Ervaren lid
  • *****
  • Berichten: 258
Re: EK2008
« Reactie #14 Gepost op: 12 december 2007, 21:24:28 »
Hallo Rudy

Je formules in Blad 2 kolom MNOP kloppen niet

Je hebt in N4 en M5 dezelfde formules staan
Ze moeten echter omgekeerd staan

Cel m5 zoekt naar de wedstrijd: Zwitserland - TsjechiŽ
Dit moet echter TsjechiŽ - Zwitseland zijn.

Ik heb ze niet allen gecontroleerd maar zo staan er dus meer in.


Willem
Willem
Hoe meer je weet hoe meer je vergeet.
Hoe meer je vergeet hoe minder je weet.
Hoe minder je weet hoe minder je vergeet.
Hoe minder je vergeet hoe meer je weet.

 


www.combell.com