Help!

PC-Problemen?
De vrijwilligers van Oplossing.be zoeken gratis met u mee!

Hulp bij posten

Recente topics

Auteur Topic: formule voor opzoeken getallen  (gelezen 3073 keer)

0 leden en 1 gast bekijken dit topic.

Offline frimout

  • Lid
  • *
  • Berichten: 68
  • Oplossing.be
formule voor opzoeken getallen
« Gepost op: 10 februari 2024, 09:51:31 »
Hallokes,

Wie kan er mij helpen om het volgende te verwezenlijken.
Ik heb de vraag in het bestandje gestoken.
Kort uitgelegd, er moet gezocht worden naar een getal in een rij en als dit getal gevonden wordt moet er in een cel een 1 geplaatst worden en anders een 0.
Zie voorbeeld
Windows 11 Pro 22H2
Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz   2.40 GHz
16GB

Offline JEC

  • Excel-Expert
  • Ervaren lid
  • *****
  • Berichten: 422
Re: formule voor opzoeken getallen
« Reactie #1 Gepost op: 10 februari 2024, 10:10:14 »
je output klopt niet helemaal met je beschrijving. Deze kun je doortrekken vanaf K2, indien je O365 hebt

=N(COUNTIF(A2:G2;$K$1:$T$1)>0)

Offline frimout

  • Lid
  • *
  • Berichten: 68
  • Oplossing.be
Re: formule voor opzoeken getallen
« Reactie #2 Gepost op: 10 februari 2024, 10:50:45 »
O365 heb ik niet.
Ik wil dat er in cel K2 een 1 geplaatst wordt als het getal in K1 voorkomt in het bereik A2:G2, anders een 0 of leeg
Windows 11 Pro 22H2
Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz   2.40 GHz
16GB

Offline Della Jordan

  • Volledig lid
  • **
  • Berichten: 152
  • Geslacht: Vrouw
  • Hey, ik ben nieuw hier !
Re: formule voor opzoeken getallen
« Reactie #3 Gepost op: 10 februari 2024, 11:51:58 »
Zoiets?
Nederlands
=ALS(AANTAL.ALS($A$2:$G$2; K1)>0; 1; 0)Engels
=IF(COUNTIF($A$2:$G$2, K1)>0, 1, 0)
Groetjes,Della

Offline frimout

  • Lid
  • *
  • Berichten: 68
  • Oplossing.be
Re: formule voor opzoeken getallen
« Reactie #4 Gepost op: 10 februari 2024, 12:40:22 »
Yep, dit is wat ik wou, hartelijk dank
Windows 11 Pro 22H2
Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz   2.40 GHz
16GB

Offline Della Jordan

  • Volledig lid
  • **
  • Berichten: 152
  • Geslacht: Vrouw
  • Hey, ik ben nieuw hier !
Re: formule voor opzoeken getallen
« Reactie #5 Gepost op: 10 februari 2024, 12:42:49 »
Graag gedaan. :)
Groetjes,Della

Offline mvdvlist

  • Lid
  • *
  • Berichten: 49
  • Geslacht: Man
  • Oplossing.be
Re: formule voor opzoeken getallen
« Reactie #6 Gepost op: 10 februari 2024, 14:54:39 »
Of gebruik Somproduct.

Offline Della Jordan

  • Volledig lid
  • **
  • Berichten: 152
  • Geslacht: Vrouw
  • Hey, ik ben nieuw hier !
Re: formule voor opzoeken getallen
« Reactie #7 Gepost op: 10 februari 2024, 16:14:57 »
Citaat
Of gebruik Somproduct.
Er zijn meer wegen naar Rome, doe er dan ook een voorbeeldje bij.
Groetjes,Della

Offline RedHead

  • Excel-Expert
  • Ambassadeur
  • *****
  • Berichten: 2.279
  • Geslacht: Man
  • Met Excel lukt 't wel.... (toch???)
Re: formule voor opzoeken getallen
« Reactie #8 Gepost op: 21 februari 2024, 21:02:50 »
al opgelost, maar voor de aardigheid nog een optie voor die extra weg naar Rome...  ;D

=--NOT(ISERROR(MATCH(K$1;$A2:$G2;0)))

=--NIET(ISFOUT(VERGELIJKEN(K$1;$A2:$G2;0)))
______________________________

Groet, Leo

 


www.combell.com