Help!

PC-Problemen?
De vrijwilligers van Oplossing.be zoeken gratis met u mee!

Hulp bij posten

Recente topics

Auteur Topic: Meldingen weergeven  (gelezen 1683 keer)

0 leden en 1 gast bekijken dit topic.

Offline Beejee Flowerdale

  • Lid
  • *
  • Berichten: 13
  • Geslacht: Man
  • Hey, ik ben nieuw hier !
Meldingen weergeven
« Gepost op: 17 januari 2022, 15:05:34 »
Het volgende:

Wanneer een cel een vooraf ingegeven waarde heeft bereikt, dan zou ik graag willen dat er een melding verschijnt.

Bijvoorbeeld:
Ik weet dat iemand 40 punten moet halen en dan zou ik wanneer ik 37 punten heb de melding willen zien van: en nog 3
en waneer ik 38 punten heb, de melding en nog 2,
en waneer ik 39 punten heb, de melding en nog 1
en wanneer ik 40 heb, dat het cijfer 40 begint te knipperen.

Weet iemand of dit mogelijk is en uiteraard hoe ik dit kan regelen.

Offline mvdvlist

  • Lid
  • *
  • Berichten: 26
  • Geslacht: Man
  • Oplossing.be
    • Zwarevrachten
Re: Meldingen weergeven
« Reactie #1 Gepost op: 17 januari 2022, 20:21:40 »
Knipperen in een cel gaat alleen met vba (denk ik).
Verder kun je een formule in bv een hulpkolom zetten NAAST de cel die je uitleest, met bv:
=als(A1>36; "Nog 4 punten";"")

Stoei daar maar eens mee. Tegelijk een vaste waarde en een formule in een cel is onmogelijk...

Offline SoftAid

  • Administrator
  • Ambassadeur
  • *****
  • Berichten: 19.301
  • Geslacht: Man
  • Nobody is perfect, not even me...
Re: Meldingen weergeven
« Reactie #2 Gepost op: 17 januari 2022, 20:44:40 »
Hallo Beejee Flowerdale,

Welkom op Oplossing.be  :)

Zoals mvdvlist al aangeeft zal je met VBA moeten werken om dat knipperen te bekomen.
Hoever gaat je kennis?

Om de formule van mvdvlist nog wat aantrekkelijker te maken kan je deze proberen:

=ALS(A1=40;"BINGO";ALS(A1=39;"Nog 1 punt";ALS(A1=38;"Nog 2 punten";ALS(A1=37;"Nog 3 punten;""))))
Groeten,

:) SoftAid :)             

Dubbelposten, het posten op verschillende forums van dezelfde vraag, dient op
voorhand gemeld te worden, met een link naar het topic op de andere site.
Overtreding van deze regel kan bestraft worden met verbanning !

Offline JEC

  • Ervaren lid
  • ***
  • Berichten: 329
Re: Meldingen weergeven
« Reactie #3 Gepost op: 17 januari 2022, 22:17:37 »
Inderdaad VBA voor nodig. Je kunt eventueel ook met voorwaardelijke opmaak werken. Dus dat de cel gewoon groen wordt bij 40

=ALS(A1=40;"Bingo";ALS(A1>36;"Nog "&40-A1&" punt(en)";""))

Offline Beejee Flowerdale

  • Lid
  • *
  • Berichten: 13
  • Geslacht: Man
  • Hey, ik ben nieuw hier !
Re: Meldingen weergeven
« Reactie #4 Gepost op: 18 januari 2022, 12:15:52 »
Dank voor alle reacties en eventuele oplossingen.

Op de vraag in hoeverre ik een expert ben met Excel kan ik heel kort zijn.
De baiskennis heb ik redelijk onder de knie, maar als je begint over VBA, dat gaat mij te ver.
Dus misschien kan iemand me daarmee helpen?

Groet
BJ Flowerdale

Offline Warme bakkertje

  • Excel-Expert
  • Volledig lid
  • *****
  • Berichten: 181
  • Geslacht: Man
Re: Meldingen weergeven
« Reactie #5 Gepost op: 18 januari 2022, 13:21:11 »
De cel die uitgelezen moet worden bevat deze een formule of breng je die getallen manueel in?

Voeg er eventueel een voorbeeldbestandje aan toe om de situatie te verduidelijken.
Windows 10 Home   NLD 64bit

Microsoft Office Professional Plus 2016 US

Offline Beejee Flowerdale

  • Lid
  • *
  • Berichten: 13
  • Geslacht: Man
  • Hey, ik ben nieuw hier !
Re: Meldingen weergeven
« Reactie #6 Gepost op: 18 januari 2022, 13:35:10 »
De cellen waar het om gaat, daar staan nu de getallen 25 en 10.
Zoals je kunt zien moet de linker speler 77 punten maken en de rechter speler 35.

Het is de bedoeling dus dat wanneer de linker speler er 74 heeft dat er dan een melding komt van "en nog 2 punten" enzovoort, enzovoort.
Voor de rechter speler geldt dat natuurlijk ook, maar die moet in dit geval 35 punten halen.

Ben ik zo een beetje duidelijk.

Bijgaand stuur ik een bestandje mee.

Offline Warme bakkertje

  • Excel-Expert
  • Volledig lid
  • *****
  • Berichten: 181
  • Geslacht: Man
Re: Meldingen weergeven
« Reactie #7 Gepost op: 18 januari 2022, 17:20:07 »
Kijk eens of je met deze verder kan.
Windows 10 Home   NLD 64bit

Microsoft Office Professional Plus 2016 US

Offline Beejee Flowerdale

  • Lid
  • *
  • Berichten: 13
  • Geslacht: Man
  • Hey, ik ben nieuw hier !
Re: Meldingen weergeven
« Reactie #8 Gepost op: 18 januari 2022, 18:33:09 »
Op zich is dit wat ik bedoel, heel erg goed hoor, maar....

Nu krijg ik de melding in een apart vensterjte als melding, het liefst had ik gehad dat de melding zou komen in het groene vlakje tussen de "Gemaakte caramboles" en het vakje :iets misgegaan....." en voor de rechterspeler natuurlijk in het vakje tussen "Gemaakte caramboles" en "Iets misgegaan?".

Heb je dit nou weten te bereiken met VBA?

Ik hoor het graag

Offline Warme bakkertje

  • Excel-Expert
  • Volledig lid
  • *****
  • Berichten: 181
  • Geslacht: Man
Re: Meldingen weergeven
« Reactie #9 Gepost op: 19 januari 2022, 11:02:47 »
Met de gevraagde aanpassingen.
Windows 10 Home   NLD 64bit

Microsoft Office Professional Plus 2016 US

Offline Beejee Flowerdale

  • Lid
  • *
  • Berichten: 13
  • Geslacht: Man
  • Hey, ik ben nieuw hier !
Re: Meldingen weergeven
« Reactie #10 Gepost op: 19 januari 2022, 14:23:19 »
Super bedankt voor de oplossing, maar......

Nu zie ik dat IK een foutje heb gemaakt en dat ik je het verkeerde bestandje heb gestuurd en daarom wil ik je het volgend heel heel heel vriendelijk vragen.
Zou je in het hierbij gevoegde bestand het gevraagd willen aanpassen, please

Ik denk dat dit voor jou een kwestie is van knippen en plakken en voor mij wordt het denk ik een hele puzzel.

Offline Warme bakkertje

  • Excel-Expert
  • Volledig lid
  • *****
  • Berichten: 181
  • Geslacht: Man
Re: Meldingen weergeven
« Reactie #11 Gepost op: 19 januari 2022, 17:00:36 »
Dit is NIET voor herhaling vatbaar.

Kijk of alles klopt in het nieuwe bestand.
Windows 10 Home   NLD 64bit

Microsoft Office Professional Plus 2016 US

Offline Beejee Flowerdale

  • Lid
  • *
  • Berichten: 13
  • Geslacht: Man
  • Hey, ik ben nieuw hier !
Re: Meldingen weergeven
« Reactie #12 Gepost op: 19 januari 2022, 18:36:39 »
SORRY SORRY SORRY SORRY, dat zal niet meer gebeuren.

Maar ontzettend bedankt voor de goede en snelle hulp.

 


www.combell.com