Help!

PC-Problemen?
De vrijwilligers van Oplossing.be zoeken gratis met u mee!

Hulp bij posten

Recente topics

Auteur Topic: Zoeken op meerdere waarden  (gelezen 587 keer)

0 leden en 1 gast bekijken dit topic.

Offline Georgyboy

  • Volledig lid
  • **
  • Berichten: 203
  • Geslacht: Man
  • Oplossing.be
Zoeken op meerdere waarden
« Gepost op: 17 januari 2021, 18:33:10 »
Beste Allen,

Graag had ik een andere formule dan meerdere ALS formule.
Huidig voorbeeld zijn 6 zoekwaarden wat gaat met meerdere als formule.
Stel dat er 100 zoekwaarden zijn dan gaat dit niet met meerdere als.

Kolom B = Waarden om te zoeken uit Kolom D
Als waarde in kolom A = aan waarde in kolom D dan is het dezelfde waarde of ok
Kolom C : proberen met index en vergelijken (wat niet lukt)

Alvast bedankt
Groeten,
Georgyboy

Offline RedHead

  • Excel-Expert
  • Ambassadeur
  • *****
  • Berichten: 2.056
  • Geslacht: Man
  • Met Excel lukt 't wel.... (toch???)
Re: Zoeken op meerdere waarden
« Reactie #1 Gepost op: 17 januari 2021, 20:09:03 »
Wat denk je van deze in cel B1 en verder?
[English] =IF(NOT(ISERROR(MATCH(A2;D:D;0)));A2;"")

[Dutch] =ALS(NIET(ISFOUT(VERGELIJKEN(A2;D:D;0)));A2;"")
______________________________

Groet, Leo

Offline Georgyboy

  • Volledig lid
  • **
  • Berichten: 203
  • Geslacht: Man
  • Oplossing.be
Re: Zoeken op meerdere waarden
« Reactie #2 Gepost op: 17 januari 2021, 20:48:22 »
Helemaal wat ik zocht :)  :thumbsup:

Dankjewel Leo  _/-\o_

Offline Warme bakkertje

  • Lid
  • *
  • Berichten: 95
  • Geslacht: Man
Re: Zoeken op meerdere waarden
« Reactie #3 Gepost op: 18 januari 2021, 01:49:45 »
Citaat
proberen met index en vergelijken (wat niet lukt)

Toch wel. :)

=IFERROR(INDEX($D:$D;MATCH($A2;$D:$D;0));"")
=ALS.FOUT(INDEX($D:$D;VERGELIJKEN($A2;$D:$D;0));"")
« Laatst bewerkt op: 18 januari 2021, 07:43:58 door Warme bakkertje »
Windows 10 Home   NLD 64bit

Microsoft Office Professional Plus 2016 US

Offline Veerj

  • Lid
  • *
  • Berichten: 24
Re: Zoeken op meerdere waarden
« Reactie #4 Gepost op: 18 januari 2021, 07:32:34 »
Als.fout ipv isfout ;)

Offline Georgyboy

  • Volledig lid
  • **
  • Berichten: 203
  • Geslacht: Man
  • Oplossing.be
Re: Zoeken op meerdere waarden
« Reactie #5 Gepost op: 18 januari 2021, 07:37:09 »
Fout uitgedrukt  ;)

Citaat
wat ME niet lukt
Citaat
proberen met index en vergelijken (wat niet lukt)

Dankjewel ! Warme bakkertje

Offline Warme bakkertje

  • Lid
  • *
  • Berichten: 95
  • Geslacht: Man
Re: Zoeken op meerdere waarden
« Reactie #6 Gepost op: 18 januari 2021, 10:27:30 »
In je 1ste Post spreek je van 100 zoekwaarden. Daarom een gouden raad van tante Kaat.  ;D

Maak van je zoekwaarden tabel een Dynamisch Gedefinieerde Tabel die automatisch langer/korter wordt naargelang het aantal elementen

zodat je in je formule daarnaar kan verwijzen ipv naar de volledige kolom D.
Windows 10 Home   NLD 64bit

Microsoft Office Professional Plus 2016 US

Offline Georgyboy

  • Volledig lid
  • **
  • Berichten: 203
  • Geslacht: Man
  • Oplossing.be
Re: Zoeken op meerdere waarden
« Reactie #7 Gepost op: 18 januari 2021, 19:49:32 »
Bedankt

Citaat
gouden raad van tante Kaat

zal vooral de gouden raad van "warm bakkertje volgen" daar kom ik heel ver mee  :D

Allen bedankt voor de bruikbare oplossingen wederom :)  :thumbsup:

Offline Georgyboy

  • Volledig lid
  • **
  • Berichten: 203
  • Geslacht: Man
  • Oplossing.be
Re: Zoeken op meerdere waarden
« Reactie #8 Gepost op: 23 januari 2021, 17:35:31 »
Dank jullie voor deze oplossing(en)  _/-\o_  :)

 


www.combell.com