Help!

PC-Problemen?
De vrijwilligers van Oplossing.be zoeken gratis met u mee!

Hulp bij posten

Recente topics

Auteur Topic: naam splitsen op eerste spatie indien veld is ingevuld.  (gelezen 296 keer)

0 leden en 1 gast bekijken dit topic.

Offline gukke

  • Nieuw lid
  • Berichten: 1
  • Geslacht: Man
  • Hey, ik ben nieuw hier !
naam splitsen op eerste spatie indien veld is ingevuld.
« Gepost op: 20 maart 2022, 15:12:07 »
Beste,

Is er een samengestelde formule die kan nakijken of een veld is ingevuld. Indien niet ingevuld moet deze cel ook leeg blijven en indien ingevuld moet in deze cel de naam gesplitst worden op spatie.
ik denk aan =ALS(A21;"";SPLIT(A21;" "))
Dit lukt niet omdat Als 0 of 1 verwacht en niet een lege cel.

Met vriendelijke groeten ,

Gunther

Offline SoftAid

  • Administrator
  • Ambassadeur
  • *****
  • Berichten: 19.376
  • Geslacht: Man
  • Nobody is perfect, not even me...
Re: naam splitsen op eerste spatie indien veld is ingevuld.
« Reactie #1 Gepost op: 20 maart 2022, 15:35:47 »
Hallo Gunther,

Welkom op Oplossing.be  :)

Ik vermoed dat je die formule wenst te plaatsen in de cel die of leeg is of waar je data wilt invoeren (die daarna gesplitst moet worden)

Als je cel leeg is, dan kan daar een formule in staan. als je er data in typt, dan wordt de formule overschreven.
Dat werkt dus niet. Kan je een voorbeeldbestandje aanhangen?

:) SoftAid :)             

Dubbelposten, het posten op verschillende forums van dezelfde vraag, dient op
voorhand gemeld te worden, met een link naar het topic op de andere site.
Overtreding van deze regel kan bestraft worden met verbanning !

Offline SoftAid

  • Administrator
  • Ambassadeur
  • *****
  • Berichten: 19.376
  • Geslacht: Man
  • Nobody is perfect, not even me...
Re: naam splitsen op eerste spatie indien veld is ingevuld.
« Reactie #2 Gepost op: 20 maart 2022, 17:47:06 »
PS: wat zijn de voorwaarden voor het splitsen van de ingevulde data?

:) SoftAid :)             
Dubbelposten, het posten op verschillende forums van dezelfde vraag, dient op
voorhand gemeld te worden, met een link naar het topic op de andere site.
Overtreding van deze regel kan bestraft worden met verbanning !

Offline RedHead

  • Excel-Expert
  • Ambassadeur
  • *****
  • Berichten: 2.217
  • Geslacht: Man
  • Met Excel lukt 't wel.... (toch???)
Re: naam splitsen op eerste spatie indien veld is ingevuld.
« Reactie #3 Gepost op: 20 maart 2022, 19:12:48 »
Laat gebruikers deze waardes in aparte cellen invoeren (voornaam, tussenvoegsel, achternaam) ipv achteraf moeilijk moeten om het te proberen te splitsen. Want hoe ga jij straks om met bijvoorbeeld Jan Karel van Hennengouwen ten Berge? Daar ga je het niet redden met je spilt...
______________________________

Groet, Leo

Offline BlackDevil

  • Oplosser
  • ****
  • Berichten: 566
  • Geslacht: Vrouw
  • Oplossing.be
Re: naam splitsen op eerste spatie indien veld is ingevuld.
« Reactie #4 Gepost op: 21 maart 2022, 09:46:40 »
ik denk aan =ALS(A21;"";SPLIT(A21;" "))

Dit kan sowieso nooit werken gezien de logische test niet aanwezig is...
als A21 wat?
Verder is de functie "split" niet aanwezig in de nederlandse versie van excel (althans toch niet in de mijne).

Makkelijkshalve zou ik het ook oplossen zoals RedHead aangeeft...

groetjes,
BlackDevil
Windows 10 Home / Intel(R) Core(TM) i3-3110M CPU@ 2.40GHz 2.40GHz / RAM : 8,00 GB (7,89 GB beschikbaar) / 64-bits besturingssysteem, x64-processor / Intel(R) 7 Series Chipset Family SATA AHCIController / Qualcomm Atheros AR8161 PCI-E Gigabit Ethernet Controller (NDIS 6.30) / Qualcomm Atheros AR9485 Wireless Network Adapter / HGST HTS541010A9E680 / Seagate Backup+ Hub 6TB / Seagate BUP Slim 2TB / Seagate Expansion Desk 5TB / HP OfficeJet 3831
Bullguard Premium Protection / Office Pro Plus 2016 NL

 


www.combell.com